RubyGems 0.9.1 – required update

In: Ruby|Ruby on Rails

20 Jan 2007

RubyGems has been updated to 0.9.1 and is a required update due to a security issue. The blog announcement reveals more:

The most important change in RubyGems 0.9.1 is that RubyGems no longer allows files to be installed outside of the installation directory.

It’s a required update as the RubyForge gem repository will soon disallow installation of gems if you have an older version of RubyGems.

Anyway, a new feature I found very useful is gem outdated, which lists the gems you have installed that are currently not the latest versions (I just realized that mongrel is actually already up to 1.0 RC!). And don’t forget multiple gem uninstallation with gem uninstall.

Update your RubyGems by running:

gem update --system

Comments are closed.