An update: I've actually deleted the existing extension on the Firefox Add-ons site and added a new one per Patrick's suggestion below, and it is now available there. And yeah, I didn't put any of the changes you guys requested in there besides getting it to work for Firefox 1.5...

I've seen your emails and comments about updating the Unread Tabs extension for Firefox 1.5, and I apologize if I haven't responded to your email personally.

Anyway, yes, the fix is extremely simple, and in fact I did try to fix it once and upload it onto the Firefox Add-ons site a long time ago last year when the extra character in the GUID was brought to my attention (to explain this a bit - each extension has its own GUID which is universally unique 32-character string, and somehow I screwed it up by inserting a GUID with 33 characters). Well, the problem is, in the developer section of the Firefox Add-ons site, the "Add New Version" function enforces the rule that a new version of an extension should have the same GUID, which is perfectly fine and expected.

So I've been trying to find a way to get in touch with the guys over at Firefox Add-ons to workaround this and to see what implications this may have, but can't find any form of contact information at the site (and no, I'm not gonna email the mozilla.org webmaster to bug him unless no one really knows how to reach the Firefox Add-ons guys). Anyone has any clue? Or maybe I should just email the mozilla.org webmaster...

Whatever the result of that, here's an updated Unread Tabs for Firefox 1.5 with a new GUID:
Install Unread Tabs | Download Unread Tabs